Май 2017 — KorP`s blog

VeeamON 2017: что 10-ка нам готовит?


На прошлой неделе прошла конференция VeeamON 2017, на ней стала доступна информация относительно новой версии Veeam 10, о которой я сегодня и буду рассказывать.
Continue reading VeeamON 2017: что 10-ка нам готовит?

23.05.2017

Posted In: Основная

Метки:

Leave a Comment

Brocade SAN Часть 4: Соединение на длинных дистанциях

Сегодня мы будем говорить о растягивании FC фабрики на длинные расстояния. Как одна из наиболее часто встречающихся задач — соединение нескольких ЦОДов. Стоит отметить, что у самих коммутаторов нет возможности работать на расстоянии более 25км, а компания Brocade не выпускает оборудования для соединения FC коммутаторов на длинных дистанциях. Но как же соединять ЦОДы, находящиеся в разных городах и даже странах? Надеюсь я вас заинтриговал, поэтому добро пожаловать под кат.
Continue reading Brocade SAN Часть 4: Соединение на длинных дистанциях

22.05.2017

Posted In: Основная

Метки: ,

Leave a Comment

Запуск WebTools FOS 6 на MacOS

И так, случилось страшное. У вас есть коммутатор Brocade, но по какой то причине у вас на нём установлена уже старая версия FOS ниже 7 версии.
В моём случае именно так оно и есть, ввиду того, что в моей домашней инфраструктуре живут старенькие Brocade 200E, которые просто не поддерживают FOS выше версии 6.2.2. Не то, что бы я большой фанат работы через WebTools, но порой и в графику хочется посмотреть. И есть с коммутатора с FOS 7 проблем нет, то с 6 вы будете получать постоянно ошибки сертификатов и WebTools не будут запускаться даже при помощи консоли, как я уже рассказывал
korp$ javaws http://адрес_коммутатора/switchExplorer_installed.html

Ах да, и главное — у вас MacOS 🙂
Для решения этой проблемы нам придётся поставить Java 1.7 а так же немного поправить её конфиг.
Сразу скажу что это понижает безопасность Java, но если вы используете её с умом и только для управления собственным оборудованием (лично у меня в браузере она отключена) то проблем возникнуть не должно.
И так, нас интересует файл /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/lib/security/java.security
В нём мы находим строку
jdk.certpath.disabledAlgorithms=MD2, RSA keySize < 1024
и нам необходимо сменить 1024 на 256.

после этих манипуляций всё прекрасно запускается из консли

18.05.2017

Posted In: Основная

Метки: ,

Leave a Comment